raismth test on Firefox & Iceweasel 19

Un consiglio per gli utilizzatori di raismth è di non aggiornare Firefox o Iceweasel oltre la versione 17.

Esiste un problema legato alla gestione dei  ‘missing plugins’  che rende inutilizzabile alcune funzioni.

Dalla versione 18 in poi avrete un problema 🙁 .

Per il resto alcuni test fatti nei laboratori segreti dell’MM Team applicando la patch  pubblicata sulla mail list di supporto (Olrait) a raismth 3.0.4 ,  sulle versioni di Firefox piu’ recenti (dalla 18 i poi)  ci confermano che l’addon si comporta ancora bene.

 

La patch e’ ‘as-is’ ovvero senza garanzia per il suo funzionamento
ne supporto per l’istallazione.

Vediamo ora come aggiungere la patch all’ addon, per prima cosa scarichiamo l’addon e successivamente la 

Download “raismth patch” f18.patch_.zip – Scaricato 223 volte – 607 B

,pubblicata sulla mail list di supporto (Olrait) .

Per la gestione del file .xpi avevo già scritto qualcosa a riguardo qui Modificare add-on firefox/iceweasel (.xpi)

Dopo aver rinominato il file da .xpi a .zip , prelevo il file da patchare : /chrome/content/raismth/rai.js

da shell mi trovo nella directory dove sono i file rai.js e f18.patch , impartisco ora il comando :

$ patch rai.js f18.patch

Fatto ciò sostituisco il file con la versione patchata e ricreo l’addon modificando l’estensione da .zip a .xpi .

Ora non resta che rimuovere la vecchia versione dell’addon da firefox/iceweasel  e installare questa versione patchata per poter tornare a visionare i contenuti del sito http://www.rai.tv/

In attesa di una nuova versione  be happy & be free

OT :

Un anno fa stava per uscire la versione 11 dell’aggiornatissimo browser.   😉

7 risposte a “raismth test on Firefox & Iceweasel 19”

  1. Io non ho il file rai.js, per cui non riesco a trovarlo e patcharlo.
    Come posso fare? A me questa soluzione non ha risolto il problema. Chi mi può aiutare?
    Grazie mille.

  2. Non è chiaro cosa hai fatto e dove hai cercato il file che non trovi.
    Segui con maggiore attenzione l’articolo che mi pare tu non abbia letto bene.

    Infine ricordo : La patch e’ ‘as-is’ ovvero senza garanzia per il suo funzionamento
    ne supporto per l’istallazione.

  3. ciao,
    ho provato a patchare ma…
    una volta ricreato il pacchetto xpi, firefox me lo trova corrotto…

    sbaglio qualcosa?

    grazie

  4. Felice che abbia risolto sacarde.

    non ho risposto prima perchè ero in vacanza 😉

    ma perchè parli di 2 file ?

    dopo aver patchato rai.js , devi rimetterlo al suo posto e ricreare l’.xpi.

Rispondi