VLC-Git 1.0 Lenny

Era da tempo che non riuscivo più ad usare VLC il mio player multimediale preferito .
Mi pareva di aver letto in giro che ci fossero problemi tra pacchetti della repo multimedia , in particolare penso fosse ffmpeg a causare problemi.
Mentre il tempo passava ho cominciato a usare con piacere Xine e mplayer che ho scoperto essere due ottimi player , ma il cruccio restava VLC ha da andare .
Ringrazio chris70 per avermi dato la soluzione , qui il link altrimenti leggete il resto della notizia .

Riporto ora il post:

I sorgenti da scaricare sono qui http://nightlies.videolan.org/build/source/ (non tutti gli snapshot mi funzionano, al momento sto usando il 20081224) se volete potete scaricare questo che sicuramente funziona.

Il necessaire per la compilazione :

# aptitude install gettext quilt nasm yasm liba52-0.7.4-dev libaa1-dev libasound2-dev libaudiofile-dev libavahi-client-dev libavc1394-dev libavcodec-dev libavformat-dev libcaca-dev libcdio-dev libdc1394-22-dev libdca-dev libdvbpsi4-dev libdvdnav-dev libdvdread-dev libfaad-dev libflac-dev libfreetype6-dev libfribidi-dev libggi2-dev libgl1-mesa-dev libglib2.0-0 libgnutls-dev libhal-dev libid3tag0-dev libidl0 libimlib2-dev libjack-dev liblircclient-dev liblua5.1-0-dev libmad0-dev libmatroska-dev libmodplug-dev libmpcdec-dev libmpeg2-4-dev libncursesw5-dev libnotify-dev libogg-dev libpng12-dev libpostproc-dev libpulse-dev libqt4-dev libraw1394-dev libschroedinger-dev libsdl-image1.2-dev libsdl1.2-dev libshout3-dev libsmbclient-dev libspeex-dev libsvga1-dev libswscale-dev libsysfs-dev libtag1-dev libtar-dev libtheora-dev libtwolame-dev libvcdinfo-dev libvorbis-dev libx11-dev libxext-dev libxml2-dev libxpm-dev libxt-dev libxv-dev qt4-dev-tools zlib1g-dev

dove presente # eseguire il comando come root , altrimenti come user

Il mio configure (qt4) :
cd /directory……

./configure --prefix=/opt/vlc-git --enable-libtool --enable-fast-install --disable-update-check --disable-gnome --disable-gtk --disable-familiar --disable-fb --enable-ggi --enable-sdl --enable-esd --enable-mad --enable-arts --enable-alsa --enable-jack --disable-pulse --enable-lirc --enable-a52 --enable-aa --enable-dvbpsi --enable-mp4 --enable-dvb --disable-satellite --enable-ogg --enable-vorbis --enable-shout --enable-qt4 --disable-slp --enable-flac --disable-skins --disable-basic-skins --enable-skins2 --enable-freetype --enable-mkv --enable-speex --enable-caca --disable-live555 --enable-libmpeg2 --enable-fribidi --enable-cdio --enable-mod --enable-theora --enable-modplug --enable-dvdnav --enable-gnutls --enable-ffmpeg --enable-ncurses --enable-smb --disable-gnomevfs --enable-bonjour --enable-mpc --enable-vcd --enable-vcdx --enable-notify --enable-twolame --enable-x264 --enable-faad --disable-zvbi --enable-telx --enable-mediacontrol-bindings --disable-atmo --enable-taglib --disable-libass --enable-libdca --enable-realrtsp --enable-alsa --enable-dv --disable-v4l --enable-v4l2 --enable-pvr --enable-svgalib --enable-dvd

i canonici :

make
# make install

e lo script per lanciarlo :

# nano /usr/local/bin/vlc-git

#!/bin/sh

PATH=/opt/vlc-git/bin:$PATH
export PATH
LD_LIBRARY_PATH=/opt/vlc-git/lib
export LD_LIBRARY_PATH
/opt/vlc-git/bin/vlc “$@”

e renderlo eseguibile

#chmod 775 /usr/local/bin/vlc-git

poi se vuoi sostituirlo alla versione ufficiale basta rimuovere quest’ultima e linkare lo script in /usr/bin :

# ln -s /usr/local/bin/vlc-git /usr/bin/vlc

Per rimuovere il tutto , andare nella cartella dove si è eseguito il comando make installa e dare

#make uninstall

Io attualmente lo sto usando e mi trovo molto bene Provare per credere !

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

*