Debian Amule : error libbfd-2.18.0.20080103.so

Sono passato a Squeeze quasi subito e dopo i primi aggiornamenti
al riavvio trovo che amule non funziona più.
Continuavo a lanciarlo dal desktop clickando sull’icona e in KDE vedevo l’asinello rimbalzare allegramente fino a che scompariva.
Ho provato allora a eseguire amule da console per verificare se l’output mi restituiva qualcosa e ho scoperto :
:~$ amule
amule: error while loading shared libraries: libbfd-2.18.0.20080103.so: cannot open shared object file: No such file or directory


Mi metto subito alla ricerca del problema e scopro che se cerco in /usr/lib trovo :

$ sudo find /usr/lib/ -name libbfd*
/usr/lib/libbfd-2.19.1.so

allora come root

cd /usr/lib/
ln -s libbfd-2.19.1.so libbfd-2.18.0.20080103.so

Dopo questa correzione è partito senza problemi !

Ho notato che l’errore è comune agli utenti di ubuntu e attulamente sta coinvolgendo anche debian , ma per ora è risolto .

ricordo che per la testing amule 2.2.3 le repo sono :

deb http://www.vollstreckernet.de/debian/ testing amule-stable wx
deb-src http://www.vollstreckernet.de/debian/ testing amule-stable wx

key

gpg --keyserver wwwkeys.eu.pgp.net --recv-key D63913EF50D0AE60
gpg --export D63913EF50D0AE60 > amule-key
apt-key add amule-key

per info andate qui

spero che ciò sia utile a qualcuno

Rispondi