Skype 4.2.0.11 on Debian jessie amd64

Mi serve quella schifezza di skype per sentire saltuariamente un parente che vive in Australia e usa mac , così scopro che è uscita la versione 4.2 mentre ho ancora la vecchia 4.0.0.8-1.

L’ultima volta che ho provato ad aggiornare alla versione 4.1.0.20-1 non ho avuto molto successo ma questa volta volevo capire perchè questa zecca di programma non va.

 

dopo aver detto un rosario al contrario ho avuto l’illuminazione (eco-compatibile)

Solitamente uso il file .deb che installo con dpkg , e anche se uso multiarch da tempo questo no si installa.

Skype non viene rilasciato nella versione a 64bit così occorre la compatibilità a 32bit introdotta da wheezy che ora ha il nome di multiarch.

La fetecchia si preleva da qui :

http://download.skype.com/linux/skype-debian_4.2.0.11-1_i386.deb

poi si prova

# dpkg -i skype-debian_4.2.0.11-1_i386.deb 
Selezionato il pacchetto skype non precedentemente selezionato.
(Lettura del database... 267607 file e directory attualmente installati.)
Estrazione di skype (da skype-debian_4.2.0.11-1_i386.deb)...
dpkg: problemi con le dipendenze impediscono la configurazione di skype:
 skype dipende da libqtwebkit4 (>= 2.1.0~2011week13).

dpkg: errore nell'elaborare skype (--install):
 problemi con le dipendenze - lasciato non configurato
Elaborazione dei trigger per desktop-file-utils...
Elaborazione dei trigger per mime-support...
Elaborazione dei trigger per hicolor-icon-theme...
Si sono verificati degli errori nell'elaborazione:
 skype

faccio una breve ricerca e vedo che manca un pacchetto come i386 , bastardi .

Cerchiamo il pacchetto incriminato

# aptitude search libQtWebKit
i A libqtwebkit-dev                                                            - libreria per motore di contenuti web per Qt - file di sviluppo                      
p   libqtwebkit-dev:i386                                                       - libreria per motore di contenuti web per Qt - file di sviluppo                      
p   libqtwebkit-qmlwebkitplugin                                                - plugin WebKit QML per Qt                                                            
p   libqtwebkit-qmlwebkitplugin:i386                                           - plugin WebKit QML per Qt                                                            
i A libqtwebkit4                                                               - libreria per motore di contenuti web per Qt                                         
p   libqtwebkit4:i386                                                          - libreria per motore di contenuti web per Qt                                         
p   libqtwebkit4-dbg                                                           - libreria per motore di contenuti web per Qt - simboli di debug                      
p   libqtwebkit4-dbg:i386                                                      - libreria per motore di contenuti web per Qt - simboli di debug

manca nella versione i386 , così lo installo

# aptitude install libqtwebkit4:i386
I seguenti pacchetti NUOVI (NEW) saranno installati:
  libgstreamer-plugins-base0.10-0:i386{a} libgstreamer0.10-0:i386{a} liborc-0.4-0:i386{a} libqtwebkit4:i386 
0 pacchetti aggiornati, 4 installati, 0 da rimuovere e 0 non aggiornati.
È necessario prelevare 8876 kB di archivi. Dopo l'estrazione, verranno occupati 32,5 MB.
Continuare? [Y/n/?]

Sta cippa di multiarch continua a replicarmi i pacchetti , azz !!!

Terminato il fix dei pacchetti mancanti ripeto l’intallazione che stavolta va a buon fine

# dpkg -i skype-debian_4.2.0.11-1_i386.deb 
Selezionato il pacchetto skype non precedentemente selezionato.
(Lettura del database... 267663 file e directory attualmente installati.)
Estrazione di skype (da skype-debian_4.2.0.11-1_i386.deb)...
Configurazione di skype (4.2.0.11-1)...
Elaborazione dei trigger per desktop-file-utils...
Elaborazione dei trigger per mime-support...
Elaborazione dei trigger per hicolor-icon-theme...

ora posso godermi quella chiavica di Skype quando serve , ma li mortacci loro e del 64bit che me tocca fà per campare ?

Avvio skype e comincio a provare che tutto funzioni.

Prima prova il microfono , che dopo essere stato abilitato da esito positivo nel perditmepo echo-sound test service , poi controllo la videocamera che in passato era sempre stata riconosciuta.

barabba@khome:~$ lsusb
Bus 002 Device 003: ID 046d:092f Logitech, Inc. QuickCam Express Plus

Per il corpo di mille balene  non va !!! altro rosario.

Mi ricordo un log di apt-listchange che rispolvero :

v4l-utils (0.8.9-1) unstable; urgency=low

  Beginning with the Wheezy release libv4l-0 will support multiarch.
  As a result of the new triplet library directory you need to update
  any preload paths. For example on an i386 system the following line

  LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so

  must be changed into

  LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so

Modifico il lanciatore in :

LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype

Avvio skype e ricontrollo che tutto sia a posto e finalmente ora pare tutto ok.

Qui mi pare che le alternative valide scarseggino  così ci si deve arrangiare usando anche software propietario.

🙁

$ad Day

8 risposte a “Skype 4.2.0.11 on Debian jessie amd64”

  1. io ho un problema invece con le libasound2:i386 la cui versione non è allineata con le libasound2:amd64; non riesco ad installarle a meno che non disinstalli gnome!!!!

    Luca

  2. Questo no mi è ancora capitato , e penso sia un errore che non avrò mai dato che non uso gnome
    Per ora mi diverto solo con KDE4 e Openbox.
    Hai provato con aptitude a vedere se riesce a risolvere le dipendenze ?

    Anche se penso che rimuovere gnome sia già la soluzione migliore 😉

  3. Ciao!
    Niente da fare, né aptitude, né gdebi risolvono il problema ed in questo momento non posso permettermi un eventuale rallentamento del lavoro causa cambio desktop manager…
    rimango in attesa di nuovi aggiornamenti.

    Luca

  4. Non ho ancora capito che versione di Debian usi.
    E aptitude lo suo comodamente , però con un pinning che preleva da unstable e raramente da experimental altrimenti ti tocca aspettare

  5. Ciao, ho una debian jessie/sid perchè alcuni pacchetti che mi servono sono lì (p.es. gpib).

    Comunque ieri ho risolto forzando la versione libasound2:i386 all’unstable che è allineata con la libasound2:amd64 della jessie.

    Grazie

    Luca

  6. a me da sempre errore come risolvo

    root@debian:/home/debian-pc/Scaricati# dpkg -i skype-debian_4.2.0.11-1_i386.deb
    dpkg: errore nell’elaborare skype-debian_4.2.0.11-1_i386.deb (–install):
    l’architettura del pacchetto (i386) non corrisponde a quella del sistema (amd64)
    Si sono verificati degli errori nell’elaborazione:
    skype-debian_4.2.0.11-1_i386.deb

    Ho installato la libreria ma nulla!

Rispondi