Debian + 2.6.30 + Skype problemi webcam

Sono passato da pochi giorni al kernek 2.6.30 sulla mia Debian testing (Squeeze)

Al riavvio , ho trovato subito alcuni problemi :

  • Driver video non funzionanti
  • Modulo di virtualbox
  • riconoscimento webcam con skype

Con un’attimo di pazienza ho risolto tutto , e il sistema ora è tornato a funzionare perfettamente con il nuovo kernel.

Non ho notato per ora grossi miglioramenti passando dal 2.6.26 al 2.6.30 , il mio hardware è rimasto lo stesso da 2 anni e non avevo alcun problema di riconoscimento delle periferiche.

Per i driver nvidia ho risolto reinstallando i driver propietari NVIDIA-Linux-x86-185.18.36-pkg1.run.

Come al solito ho lanciato una console con  ctrl+alt+F1 , ho terminato kdm e installato i nuovi driver con il comando

CC=/usr/bin/gcc-4.3 sh NVIDIA-Linux-x86-185.18.36-pkg1.run

Per il problema con virtualbox , mi sono spostato in /etc/init.d e poi ho eseguito come root :

./vboxdrv setup

e ho ricompilato il modulo.

Ora per skype rimaneva il problema della webcam che non veniva riconosciuta , e non funzionando neppure con camorama i miei dubbi si infittivano anche perchè camorama e skype erano gli unici programmi installati per testare la mia webcam .

Avevo letto da qualche parte che questo nuovo kernel (2.6.30) conteneva i driver per diverse webcam .

Installando cheese ho scoperto che la webcam funzionava , perciò rimaneva un problema di skype , che ho risolto modificando il lancio dell’applicazione così :

$ LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype

ho provato anche questo altro comando consigliato da xtow

$ LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so skype

e anche così funziona perfettamente.

Ora tutto è tornato a funzionare .

Happy Debian !

11 risposte a “Debian + 2.6.30 + Skype problemi webcam”

  1. Ho aggornato oggi Skype alla versione 2.1.0.47 beta.
    Come al solito ho prelevato la versione statica e l’ho scompattata nella home.
    Ho creato il link simbolico in /usr/bin e con lo stesso codice di esecuzione , anche il nuovo skype funziona senza problemi .

  2. Sono passato alle 2.6.30 e i driver ati non fanno piu 🙂 visto che quelli proprietari non danno piu supporto alla mia scheda ora sono passato agli open.
    Magari ora dopo un paio di aggiornamenti hanno cambiato qualcosa ma per intanto uso ancora i vesa….

  3. Finalmente con la nuova versione di skype 2.1, è possibile avere una luminosità decente .
    Era stato scritto qui : http://www.mmbarabba.it/?p=370 come modificarla , ma nella versione 2 dopo alcuni secondi le tenebre ritornavano a impossessarsi della web-cam .

    Ora anche in condizioni di quasi buio la web-cam non presenta più il problema .

    Resta un’immagine di bassa qualità , non confrontabile con un mac , e lo dico perchè ho provato .

    Ma sempre meglio di niente ……….

  4. Nel caso aveste a che fare con una debian 64 bit , non installate l’ultima versione beta 2.1 , a 64 crasha al login , usate la 2.0.0.72 . Il comando cambia rispetto alle normali distro 32 bit on :

    LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so skype

    Ringrazio barabba per la collaborazione nel set della mia squeeze 64 bit .

  5. Grazie a quanto avete scritto, sono riuscito a far partire la webcam sull amia lenny 64bits con kernel 2.6.30 (backports).
    E’ bastato lanciare in un terminale il comando
    LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so skype

    …ora pero’ ho un altro problemino, da imbranato quale sono…
    …come integrare questo comando in un lanciatore di gnome? 🙁
    Grazie…

  6. Grazie delle dritte, finalmente sono riuscito a far funzionare l’ultima versione di Skype con tanto di webcam.
    Per chi con Debian 64 bit non avesse le librerie v4l a 32bit il pacchetto da installare è lib32v4l-0

  7. io invece non riesco a vedere l’immagine della web cam con la mia squeeze!!!! 🙁 ho provato tutti i comandi e con la mia web una wt trust1400 si accende la lucina blu ma non vedo nessun video…

  8. Ho aggiunto skype tra i preferiti di kde con squeeze.

    come posso avviarlo con le opzioni (LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype) cliccando sopra l’icona di skype ?

    scusa la banalita’.

    grazie e ciao

  9. forse ho risolto da solo: anziche’ fare click con tasto destro sull’icona di skype ho cliccato sul bordo grigio del menu’ e selezionato “menu’ editor”.
    ho quindi modificato il comando di skype nella cartella internet e salvato.

    spero di non aver fatto disastri.
    forse altre strade preferibili ?

    grazie e ciao.

Rispondi