kmix reset some alsamixer setting

Da circa un mese o giù di lì, il PC soffriva di uno strano problema.

All’ avvio della macchina trovavo il volume un pò più basso del solito e il microfono che anche se dava l’ output non funzionava con skype.

La scheda audio funziona da anni anche se é stata inserita sul nuovo PC da 8 mesi, ed è la SB Live Platinum (LINK).

Lanciando alsamixer ci si trova a dover maneggiare circa  30 volumi alcuni dei quali mi sono ancora ignoti, e anche dopo aver sistemato la configurazione con

#alsactl store

la situazione al successivo riavvio tornava ad essere difettosa.

Controllo il file /var/lib/alsa/asound.state e non è stato modificato dall’ ultimo lancio di alsactl store .

Faccio alcuni test per capire se è il riavvio o solo il semplice logout dalla sessione di KDE4 e alcuni particolari cominciano a lanciare sospetti su KDE4, infatti  all’ azione di logout i settaggi vengono persi.

I volumi soggetti al reset sono BASS, TREBLE e AC97 , i primi 2 si occupano dei bassi e degli alti e danno un suono un pò più ricco sui 4 satelliti e sul sub , mentre le due regolazioni su AC97 si occupano di gestire l’ output e il capture sul microfono collegato nella parte posteriore della SB LIVE.

Mi muovo per prima cosa nel pannello impostazioni di sistema di KDE dove perdo alcune ore a smanettare inutilmente finchè trovo direttamente nella barra di kmix nella scheda impostazioni la finesta configura kmix...

Mi è bastato togliere la spunta da : Rirpistina i volumi all’ accesso .

Ora tutto è tornato a posto.

 

Non so se prima la spunta c’era e tutto funzionava o se è apparsa nei recenti aggiornamenti, quello che mi basta è che funzioni senza dover maneggiare alsamixer ad ogni riavvio .

 

be patient, KDE4 is your friend 😉

 

 

 

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

*